cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Intuit

Error: It looks like you've got an old version of Internet Explorer

If you have an outdated version of Internet Explorer (IE), you may get this error when opening QuickBooks desktop:

QuickBooks Desktop doesn't work with your version of Internet Explorer.
Please upgrade Internet Explorer to version 11.0 or above.

Internet Explorer is the default browser of QuickBooks. It is used for services such as Online Banking, Payroll, Payments, etc., and whenever there is a need to connect to the web. As such, a supported IE version is required for online transactions.

To resolve this error, upgrade your Internet Explorer.

  1. Close QuickBooks.
  2. Upgrade to IE 11.
  3. Reopen QuickBooks Desktop.

Frequent Asked Questions (FAQs)

What is end of support for Internet Explorer 10?

In January 2016, Microsoft ended support for Internet Explorer (IE) 10 and below. This means that older versions of Internet Explorer will no longer receive critical, or even non-critical software updates, including security updates to patch vulnerabilities that may be exploited by malware. Regular security updates help protect computers from malicious attacks and help keep users and their data safe. So upgrading and staying current with security updates and patches is important.

What does this mean for QuickBooks?

QuickBooks Desktop will no longer support older versions of Internet Explorer (IE 10 and below) because we value keeping customer data secure and want you to have the best product experience possible.

Upgrade to Internet Explorer 11 to ensure secure and uninterrupted access, as some key QuickBooks Desktop features do not work on unsupported versions of IE.

Will this apply to me even if I am not using connected services such as Payroll or Payments?

There are several features within QuickBooks Desktop beyond Payroll or Payments that require some or all components of Internet Explorer. This includes, but is not limited to, Help pages, Online Banking and connected apps.

How do I know what version of Internet Explorer I am using now?

  1. Open Internet Explorer.
  2. Click the gear icon. (Older versions may show Help menu instead.)
  3. Click About Internet Explorer.
You’ll find the major version listed on the pop up screen.

What versions of Windows Operating System support Internet Explorer 11?

  • Internet Explorer 11 is included in Windows 10 and Windows 8.1.
  • Windows 7 users must upgrade to Internet Explorer 11 to continue using QuickBooks Desktop.
  • Windows XP, Windows Vista and Windows 8 are no longer supported by Microsoft and Internet Explorer 11 is not available on these Windows versions. You must upgrade your operating system to Windows 7, Windows 8.1, or Windows 10 to continue using QuickBooks Desktop. Visit Microsoft’s Windows store for purchase information and help with upgrading your operating system.

What are the system requirements for Internet Explorer 11?

How do I upgrade to Internet Explorer 11?

Visit the Internet Explorer site to download Internet Explorer 11 for your Windows Operating System.

Why am I seeing a message to upgrade to Internet Explorer 11.0 when it is already installed?

If your computer already has Internet Explorer 11.0 or above installed and you continue to be prompted to upgrade to Internet Explorer 11.0 or above, please see possible reason and solution at Warning that Internet Explorer 11.0 is required when it is already installed

Where can I learn more about Microsoft’s plans for Internet Explorer?

See Microsoft’s Internet Explorer Lifecycle Policy FAQ.