cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Intuit

Operating System, Internet Explorer and .Net framework requirements for QuickBooks Desktop 2015 and earlier

If you are using QuickBooks 2014 / QuickBooks Enterprise 14.0 or earlier, you may see the message:

Is your system security up to date?

Due to the new TLS 1.2 security protocol, your version of QuickBooks may not work with many features that use an Internet connection after June 30, 2018. You may need to update your system to keep features such as product re-installation, password reset, and Intuit Data Protect.

User-added image

TLS 1.2 is an internet security protocol that is quickly becoming an industry security standard. You can visit this PCI Security article for more information. In order to provide greater security and abide by the security standards, all connections used by QuickBooks Desktop to access Intuit services will need to meet certain system requirements after June 30, 2018. At this date, older TLS versions are no longer supported for compliance reasons. If these requirements are not met, services that include, but not limited to, the following will be impacted:

What you need to do

  • If the listed services/items are not needed or important to you, you can continue using your current QuickBooks version.
  • If you are using QuickBooks 2012 to 2014 and you only need access to QuickBooks Desktop activation on a new computer and the Password reset tool, make sure you meet the following system requirements and then run the TLS 1.2 Readiness tool. The tool updates your system to become TLS 1.2 compliant provided it meets all Windows Operating System, Internet Explorer and .Net requirements listed below.
  • If you need all the listed services/items or if you are using 2011 and earlier and need any of the listed items, you will need to upgrade to the latest QuickBooks version and meet all these system requirements.
  • (UK only) If you need access to VAT e-file you will need to upgrade to the to the latest QuickBooks version and meet all these system requirements. For more information, see QuickBooks Desktop VAT e-filing & Making Tax Digital (UK).


Operating System The operating system needs to be Windows 7 or later. Appropriate operating systems include:
  • Windows 7
  • Windows 8.1
  • Windows 10
  • Windows Server 2008 R2
  • Windows Server 2012 R2
  • Windows Server 2016

Visit Microsoft’s Windows store for purchase information and help with upgrading your operating system.

Internet Explorer Please make sure that you are using Internet Explorer 11 for the best security, and continuing updates by Microsoft.
  1. Close QuickBooks Desktop.
  2. Upgrade to IE 11.
  3. Reopen QuickBooks Desktop.
.Net Framework The .Net version will need to be 4.5.2 or greater. Please update to a later version of .Net as needed.
  1. Download .NET Framework from Microsoft's website.
  2. Save the file to your desktop, then double-click the file and follow the instructions on the screen to install.
  3. Reboot after the installation.
  4. If you encounter any errors while installing .NET Framework, please contact a qualified IT professional or Microsoft.
Internet Explorer Group Policy If prompted by an error message, you may need to talk to your IT person/department to allow TLS 1.2 protocol in Internet Explorer.
  • See this Microsoft article for more information on how to default to TLS1.2 when group policies show that you have correct Internet Explorer, but do not have TLS 1.2 enabled.
  • You may need an IT professional to do this for you.

Back to resolution list