cancel
Showing results for 
Search instead for 
Did you mean: 
Intuit

QuickBooks Desktop system requirements

Find out the system requirements before you install your QuickBooks Desktop. This will ensure compatibility and prevent system related issues when you start using the program.

Note:
  • This article uses the term natively installed which means it was installed on a particular system or environment that it was designed for. It also means that it doesn't need to run in a virtual environment or emulation software.
  • Windows Home Server Edition is not supported for all QuickBooks Desktop versions mentioned.

This article is part of a series that covers basic information about setting up QuickBooks Desktop.

QuickBooks Desktop 2019

Operating systems:

  • Windows 10, all editions including 64-bit, natively installed1
  • Windows 8.1 (Update 1), all editions including 64-bit, natively installed
  • Windows 7 SP1, all editions including 64-bit, natively installed
  • Windows Server 2016
  • Windows Server 2012 R2
  • Windows Server 2011, Standard and Essentials
  • Windows Server 2008 R2 SP1

Database servers

  • Windows - Windows Server 2016, Windows Server 2012 R2, Windows Server 2011, Windows Server 2008 R2 SP1, Windows 10, Windows 8.1 (update 1) or Windows 7 SP1 (Enterprise and Professional editions only), natively installed.
  • Linux - When using QBES Database Server-only installation – OpenSuse 42.3, Fedora 27, Red Hat Enterprise 7 (RHEL 7.4)


See System requirements for QuickBooks 2019 and Enterprise Solutions 19.0 and System requirements for QuickBooks for Mac 2019 for a complete list of requirements.

QuickBooks Desktop 2018

Operating systems:

  • Windows 10, all editions including 64-bit, natively installed
  • Windows 8.1 (Update 1), all editions including 64-bit, natively installed
  • Windows 7 SP1, all editions including 64-bit, natively installed
  • Windows Server 2016
  • Windows Server 2012 R2
  • Windows Server 2011 SP1
  • Windows Server 2008 R2 SP1

Database servers:

  • Windows - Windows Server 2016, Windows Server 2012 R2, Windows Server 2011 SP1, Windows Server 2008 R2 SP1, Windows 10, Windows 8.1 (Update 1), or Windows 7 SP1 (Enterprise and Professional editions only), natively installed
  • Linux - Only supported with QuickBooks Database Server Manager OpenSuse 42.2, Fedora 25, Red Hat 7 (Update 3)

See System requirements for QuickBooks 2018 and Enterprise Solutions 18.0 for a complete list of requirements.

QuickBooks Desktop 2017

Operating systems:

  • Windows 10, all editions including 64-bit, natively installed
  • Windows 8.1 (Update 1), all editions including 64-bit, natively installed
  • Windows 7 SP1, all editions including 64-bit, natively installed
  • Windows Server 2012 R2
  • Windows Server 2011
    Important: Windows Server 2011 is only supported with QuickBooks Desktop 2017 R4 or QuickBooks Desktop Enterprise 17.0 R4 and later versions.
  • Windows Server 2008 R2 SP1

Database servers:

  • Windows - Windows Server 2012 R2, Windows Server 2011 (only supported with QuickBooks Desktop 2017 R4 or QuickBooks Desktop Enterprise 17.0 R4 and later versions, Windows Server 2008 R2 SP1, Windows 10, Windows 8.1 (Update 1), or Windows 7 SP1 (Enterprise and Professional editions only), natively installed
  • Linux - Only supported with QuickBooks Database Server Manager - OpenSuse 42.1, Fedora 23, Red Hat 7 (Update 2)

See System requirements for QuickBooks 2017 and Enterprise Solutions 17.0 for a complete list of requirements.

QuickBooks Desktop 2016

Operating systems:

  • Windows 10, all editions including 64-bit, natively installed
    Important: Windows 10 is only supported with QuickBooks Desktop 2016 R7 and Enterprise 16.0 R7.
  • Windows 8.1, all editions including 64-bit, natively installed
  • Windows 7, all editions including 64-bit, natively installed
  • Windows Vista (SP2 or later), all editions including 64-bit, natively installed
  • Windows Server 2012, Windows Small Business Server 2011, Small Business Server 2008
  • Windows Server 2008 R2, Windows Server 2008, including 64-bit, natively installed

Database Servers:

  • Windows - Natively installed Windows 8, Windows 7 or Vista (SP2) with UAC on, Windows Server 2011, Windows Server 2008 R2, Windows Server 2008, Windows Server 2008 - Terminal Server Config., and Windows Small Business Server 2008
  • Linux -  Only supported with QuickBooks Database Server Manager — OpenSuse 13.2, Fedora 21, Red Hat 7


See System requirements for QuickBooks 2016 and Enterprise Solutions 16.0 and System requirements for QuickBooks for Mac 2016 for a complete list of requirements.