cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member

QuickBooks Pro 2019 on 4K monitor

I just updated to QuickBooks Pro 2019 on a Windows 10 (version 1809) and once again, I'm having an issue in scaling for a 4K monitor.Because of the high resolution (3840 X 2160) Windows scales apps to 200%.

 

QuickBooks is PROCESS_PER_MONITOR_DPI_AWARE which means that it is not scaled by Windows but by the app and is scaled at 100%, (96dpi)  which means everything is tiny and almost impossible to read.

Checking the High Scaling override for QBW32Pro.exe in the compatibility settings does not change the scaling. And I am not going back to changing the Windows scaling for everything else just so I can read the text in QB. All the other suggestions in help still do not change the scaling so it is readable.

 

I then tried having Windows look for an external .manifest file and followed the directions at

https://www.danantonielli.com/adobe-app-scaling-on-high-dpi-displays-fix/

There was even a subsequent post to further edit the manifest file for QB but that didn't work either. This fix worked on QuickBooks Pro 2015 but it is not working now.

 

The REAL problem is that QuickBooks should be PROCESS_SYSTEM_DPI_AWARE which would scale correctly for whatever resolution you are running.

 

While we are all waiting for this fix, does anyone have a solution? Anyone?

 

Marty

 

 

4 Comments
Established Community Backer ***

Re: QuickBooks Pro 2019 on 4K monitor

The link you showed seems to be dated.  Take a look at this one from December:

https://quickbooks.intuit.com/community/Help-Articles/QuickBooks-Desktop-display-issues/m-p/201768

 

The first solution looks like it may work for you.

  • Right-click the QuickBooks icon, then select Properties.
  • On Compatibility tab, select Disable display scaling on high DPI settings.
  • Select Apply, then OK.
  • Open QuickBooks and check to see if the windows are visible.

 

Active Member

Re: QuickBooks Pro 2019 on 4K monitor

Pete -  in Windows 10,  Ver. 1809 the settings have changed  (see attached) .

I checked High DPI scaling override for "Application" and it has no effect.

I changed it to override for "System" and that does work but it also effects other applications.

The "problem" is QuickBooks  is not DPI aware and it should be with all the high definition monitors in use.

 

 

 

 

QuickBooks Team

Re: QuickBooks Pro 2019 on 4K monitor

Hello there, @GibMacs.

 

I appreciate you running some tests and providing updates about the steps you've tried. I'm here to help direct you in adjusting the screen scale setup.

 

Modifying the default settings of your Windows DPI and screen resolution is easier with the screen sharing tool. Since you've already tried the steps on the article and are still unable to get your display issue fixed, I recommend contacting our Technical Support Team.

 

They'll be needing your company details to pull up your account and have the screen sharing session. That will ensure your information's privacy and security.

 

Here's their new phone directory link: Contact the QuickBooks Desktop Customer Support Team.

 

Keep me posted on how the call went, GibMacs. We're both in this together. If you have other questions or concern about QuickBooks, just let me know. Take care and have a good one.

Experienced Member

Re: QuickBooks Pro 2019 on 4K monitor

I agree, QB needs to be follow standards and allow for proper scaling in any windows situation. restricting to "how it was designed" it short sighted and extremely limiting. Another example is the extraneaous restrictions QB makes on their "multi-monitor" support, which do not support the real world of multiple monitors no anything like proper screen scaling.

 

Keith