cancel
Showing results for 
Search instead for 
Did you mean: 
Established Member
Solved

Past Due Stamp

Just updated to QB 2018.  Now when entering invoices, the past due stamp shows immediately.  I have followed the suggested steps, my terms are net 90 and the "Past Due" stamp is still showing up...no matter what I do.  Resolution steps please and thank you!!!

Best answer 05-31-2018 08:48 AM

Accepted Solutions
QuickBooks Team

Re: Past Due Stamp

Hey there, @djagiella

 

I'm here to help you get up and running with your new QuickBooks 2018 edition. I have some steps I'd like you to take to verify everything is set up properly with your terms. Even though you have the 90-day term set, it could be the term itself is not set properly for 90 days, or you might need to Rebuild your data. First I'll have you verify the term. Here's how: 

  • In the upper left-hand corner, select Lists.
  • Click Customer & Vendor Profile Lists.
  • Choose Terms List.
  • Find your Net 90 term, right-click it and select Edit Term
  • Make sure the parameters are set (for a Net 90 term, the Standard bubble should be selected and in Net due in should say 90).
  • Click OK to save your changes.

Pull up an invoice once more. If you're still seeing the past due stamp, I recommend Rebuilding your data. Here's how:

Note: it is highly recommended you perform these steps on the computer hosting the company file.

  • In the upper left-hand corner, go to File, and then Utilities.
  • Select Rebuild Data.
  • QuickBooks will ask to close all windows. Click OK.
  • The program will inform you it needs to run a backup before it can Rebuild the data. Click OK again.
  • On the next window, select Options.
  • Click Browse... to pick where the file should be saved (you can save it on your desktop).
  • Choose No verification, and click OK to continue.
  • Pick Use this Location, and then select Next
  • Click Next again, and save the file. 
  • Once the backup is finished, the Rebuild will run.

Once the Rebuild is finished, try creating a new invoice to see if the issue is still persisting. If it is, I've attached a helpful article with additional steps to troubleshoot data damage in your file. You can find that here: https://community.intuit.com/articles/1501314-resolve-data-damage-on-your-company-file .

 

Should you want to work with an agent directly, I've also included a link to the Contact Us page: https://help.quickbooks.intuit.com/en_US/contact . If you have any questions for me, leave a comment below so I can get back to you.

19 Comments
QuickBooks Team

Re: Past Due Stamp

Hey there, @djagiella

 

I'm here to help you get up and running with your new QuickBooks 2018 edition. I have some steps I'd like you to take to verify everything is set up properly with your terms. Even though you have the 90-day term set, it could be the term itself is not set properly for 90 days, or you might need to Rebuild your data. First I'll have you verify the term. Here's how: 

  • In the upper left-hand corner, select Lists.
  • Click Customer & Vendor Profile Lists.
  • Choose Terms List.
  • Find your Net 90 term, right-click it and select Edit Term
  • Make sure the parameters are set (for a Net 90 term, the Standard bubble should be selected and in Net due in should say 90).
  • Click OK to save your changes.

Pull up an invoice once more. If you're still seeing the past due stamp, I recommend Rebuilding your data. Here's how:

Note: it is highly recommended you perform these steps on the computer hosting the company file.

  • In the upper left-hand corner, go to File, and then Utilities.
  • Select Rebuild Data.
  • QuickBooks will ask to close all windows. Click OK.
  • The program will inform you it needs to run a backup before it can Rebuild the data. Click OK again.
  • On the next window, select Options.
  • Click Browse... to pick where the file should be saved (you can save it on your desktop).
  • Choose No verification, and click OK to continue.
  • Pick Use this Location, and then select Next
  • Click Next again, and save the file. 
  • Once the backup is finished, the Rebuild will run.

Once the Rebuild is finished, try creating a new invoice to see if the issue is still persisting. If it is, I've attached a helpful article with additional steps to troubleshoot data damage in your file. You can find that here: https://community.intuit.com/articles/1501314-resolve-data-damage-on-your-company-file .

 

Should you want to work with an agent directly, I've also included a link to the Contact Us page: https://help.quickbooks.intuit.com/en_US/contact . If you have any questions for me, leave a comment below so I can get back to you.

Active Member

Re: Past Due Stamp

Hi, I'm having same issue since 2018. It happened with the update. I've done reduilds, re expanded from a portable company file, set the terms to 90 days, etc etc, nothing works. Any invoice older than one day is marked "past due". It doesn't print, but still, can't Intuit figure this out? We're not paying your crazy fees to deal with this nonsense.

Active Member

Re: Past Due Stamp

Its been over a year and they still haven't fixed this problem with Pro 2019.  I could go back to excel and e-mailing the spread sheet

QuickBooks Team

Re: Past Due Stamp

Hello, @JoenotJoseph.

 

Welcome to the QuickBooks Community, and thank you for taking to time seek out our help. Earlier in this thread, I posted some troubleshooting steps to help with resolving this issue. Have you had a chance to verify your terms are set properly, or try the data damage troubleshooting? If you have already, or once you have the opportunity, post here once more with what your end results are. Should you still have trouble after performing what I've recommended, please include screenshots of the affected terms and their set up; this will help me to determine what to try next

 

It's my priority to get this resolved, so don't hesitate to ask any additional questions about this or anything else QuickBooks. In the event you would like to be rid of the past due stamp on your invoices, you can remove the mark entirely from your forms by following this article here: Show Past Due stamp on invoices.

Note: look under the section titled "Turn off the Past Due stamp".

 

As I mentioned before, should you need anything else, you can find me right here in the community. I look forward to hearing from you!

Established Member

Re: Past Due Stamp

I am so frustrated with having this issue.  I have gone thru all the steps and my past due keeps showing up on my invoices.  It doesn't print when I print the invoice, it's just very annoying.  The issue I am now having is when I send an invoice to my customer the email note that is from Quickbooks (cover email) keeps printing in red the due date on my cover email.  The red due date is the service date I typed on the invoice, not the due date.  How do I fix this?  I have attached a screen shot to show you what I am experiencing.  Thank you!

 

I had trouble attaching the file.  Here is what is showing on the cover email.  The due date printed in red is actually the service date not the due date.  How do I delete this from future cover emails?

 

Invoice   Due:11/06/2018
146
Amount Due: $82.02 
Highlighted
QuickBooks Team

Re: Past Due Stamp

Hey there, @wakeupinmaui.

 

Welcome, and thank you for joining this discussion here in the Community. Also, thank you for providing me with what you've tried so far to resolve this. Since you've tried everything recommended prior, I'd like you to try one more thing to rule some probable causes. Do you mind changing your form template to a different one in QuickBooks? The reason for this is that you may have a broken template, which could very easily be linked to why the service data is showing instead of the due date, and why the "due date" is showing in the first place.

 

For your reference, I've included a link to an article on using and customizing form templates, just in case you need it down the road: Use and customize form templates.

 

After switching to a different template, try sending a mock email of the same invoice to yourself and see if the cover letter is showing in the same way. Be sure to comment back with your findings so I can assist you further. Should you have additional questions about this or anything else QuickBooks, don't hesitate to ask me here in the Community. I'll keep an eye out for your response.

Established Member

Re: Past Due Stamp

Thank you Clay for trying to assist me.  I tried emailing myself a mock different template and it appears you may be correct that I have a broken template.  My cover email is still showing a due date but with the mock email it shows a 30 day due date which is what I selected with net 30.  I spent a lot of time creating a custom invoice template for our business with the help of your on the phone support staff.   Is there an easy way to copy my information into a new template without having to recreate the entire invoice?   Also is there anyway not to have any due date show up at all on the cover email?  I'm frustrated trying to bill my customers and fix all these issues so I really appreciate your assistance.  So far QuickBooks Pro has not been as easy of an accounting program as I had hoped it would be.  Thank you.

QuickBooks Team

Re: Past Due Stamp

Hello wakeupinmaui, 

 

Thanks for providing such detailed information. Let's work together and go through your concern one-at-a-time and resolve them. 

 

Are you referring to creating a new template using an existing one? If so, you can use the Duplicate or make a copy of a template functionality in QuickBooks Desktop. This allows you to apply the design and format of a customized template to a new one. 

 

Here's how:

  1. Go to the Lists menu at the top menu bar, then Templates.
  2. From the Templates list, select the template you want to copy.
  3. In the Templates drop-down, choose Duplicate
  4. Pick the type of form you want this template copy to be used for.
  5. Click OK.

You can modify it depending on which information you want to add. If you want to use the new one to your invoice, just toggle the template you want to use . To do so:

  1. Open an invoice.
  2. Choose which template you want to select in the Template field (see screenshot 1).

Check out the second part of this article for more details:

 

Use and customize form templates

 

Now, for your second concern; you'll be able to add/alter the cover email and get rid of the due date detail in your transactions. This can help save your time since there isn't a need for you to manually remove it prior to sending the invoice. 

 

These steps can guide you through:

  1. From the Edit menu, choose Preferences, then Send Forms.
  2. In the Company Preferences, choose Email as Delivery Method Default.
  3. Select the Template Type you want to create.
  4. Highlight the template you want to modify, then pick Edit.
  5. Remove the [Due Date] fields.
  6. Click Save

To set the template as default, make sure to select Default prior to saving it. To know more about how this functionality works, check out the article below:

 

Customize email templates in QuickBooks

 

These steps should get you going!

 

Please note that we are committed to ensuring you can get the best help possible in using QuickBooks Desktop. If you have questions with the product, feel free to let me know. I'll be around.

screenshot 1.PNG

Community Contributor *

Re: Past Due Stamp

How do you permanently get rid of that irritating past due stamp?  If an invoice is created on 10/1/2018 and the terms are 60 day it is not past due the moment you save it.  It is NOT past due until it has been 60 days or more.  I can turn it off one invoice at a time but I don't want to go through 500 invoices and do that. 

Community Contributor *

Re: Past Due Stamp

Pasy due stamp shows up when invoices are not past due.  They have no even been sent to the customer yet.  This is not a new problem.

QuickBooks Team

Re: Past Due Stamp

Hi there, White Female.

 

Thanks for joining this thread. I'm here to provide some additional information about Past due stamp on Invoice and guide you to the right support.

 

Technically, QuickBooks invoices will only post a past due stamp on the time these transactions are due. In your case, you'll need to review each transaction to see if they are old edited transactions that are due in the past. However, if the issue the same thing happens, you'll need to process the troubleshooting steps provided by my colleague ClayJ on his post.

 

If the issue still persists, I encourage you to contact our QuickBooks Desktop Support Team. They have additional tools to pull up your account and investigate this further. 

 

Here's how to contact our phone support:

  1. Click this link: https://help.quickbooks.intuit.com/en_US/contact.
  2. Select the version of QuickBooks, click Contact Us.
  3. Type-in Technical Support on the search bar.
  4. And click Get the Phone number below.

You may also check this article for additional reference: Show Past Due stamp on invoices.

 

Please let me know how it goes. If you have any other concerns about Invoice don't hesitate to leave a comment below. Have a good day ahead. 

Established Member

Re: Past Due Stamp

How do you turn off one at a time?

QuickBooks Team

Re: Past Due Stamp

Hello there, FL User.

 

Thanks for joining this thread. Allow me to help and guide you on how to turn off pay stub in QuickBooks Desktop. 

 

Are you trying to turn off the past due on your open invoices? If so, you can simply select the Turn Off link to remove the "Past Due" stamp. I attached a screenshot below for your reference. 

 

For additional reference, you can check this article: Show Past Due stamp on invoices.

 

If you need further assistance with the steps, I recommend calling our QuickBooks Desktop Support Team. They have additional tools to pull up your account and do a remote session. You can check my post above for the steps on how to get in touch with our phone support. 

 

That should do it! Please know that I'm just a post away if you have other questions about Past Due stamp. Wishing you and your business continued success. 

Established Member

Re: Past Due Stamp

Thank you, but that link does not appear on my invoice.

QuickBooks Team

Re: Past Due Stamp

Hello there, FL User.

 

I'm here to provide some additional clarification on turning off Past Due invoices.

 

Can you share which version of QuickBooks Desktop you're currently using? The option to turn off Past Due Stamp on invoices is only available in QuickBooks Desktop for Windows 2018 and later.

 

For unsupported versions, you're unable to see the option for Past Due Stam through the invoice template. I'm adding an article below for more information about what I'm referring to:

 

Show Past Due stamp on invoices.

 

Please let me know if I can be of additional assistance by providing more details below. The Community is always here to help.

Experienced Member

Re: Past Due Stamp

I have QB Pro 2016,  2017,  &  2018.My invoices are NOT past due.  I have not even mailed are emailed them.  Only just created.  There won't be a 2019 for me.   And I did the same thing put 90 days in due date.  nothing works.

QuickBooks Team

Re: Past Due Stamp

Let's check to see if the invoice template is not damaged, ShadyLady.

 

Here's how:

  1. Click File, then select Utilities.
  2. Click Rebuild Data.
  3. Click OK when you see Rebuild has completed.

Then, run the Verify Data Utility Tool.

  1. Click File, then select Utilities.
  2. Click Verify Data. If you see QuickBooks detected no problem with your data, select OK

We're always here to help if you have additional questions. Feel free to reach out.

Experienced Member

Re: Past Due Stamp

This does not work.  I have even tried to chg. due dat to 120 days.  It still gives me  past due s soon as I create invoice.  I have not emailed or printed to mail yet.  I can remove it  on each individual invoice but with a hundred invoices that is not something I want to do.

QuickBooks Team

Re: Past Due Stamp

Thanks for getting back to us, ShadyLady.

I appreciate your effort in performing some troubleshooting steps to resolve the issue. Allow me to take over and help you sort this out.

 

You may want to use terms on your invoices. QuickBooks will treat invoices as DUE UPON RECEIPT if you will not use TERMS in your invoices.

 

Here's an article with detailed steps and information about payment terms: https://quickbooks.intuit.com/community/Payments/Set-up-payment-terms/td-p/203687.

 

If you're still getting the same issue, let's try repairing your QuickBooks Desktop. Repairing QuickBooks can to fix program-related issues or errors.

 

Here's how:

 

  1. Restart your computer to close unnecessary programs interfering with QuickBooks.
  2. Back up your QuickBooks company file.
  3. Select Start and then Control Panel. (In Windows 8/8.1: From the Start menu, open Search and type Control Panel. From the results, select Control Panel.)
  4. Select Programs and Features. If necessary, choose to Uninstall a program.
    (If you don't see these options, select Programs, then Program Features.)
  5. Select QuickBooks in the list of programs and choose Uninstall/Change.
  6. Select Continue, then Next.
  7. Select Repair then Next. Wait for the Repair to complete.
  8. Choose Finish. Restart your computer if prompted.
  9. Don't forget to download the latest QuickBooks release and the latest payroll tax table when you open QuickBooks.

I've got an article for your reference: https://quickbooks.intuit.com/community/Getting-Started/Fix-QuickBooks-Desktop-Windows/m-p/201490.

 

Please let me know how it goes or if you ran into a different situation by a reply below.