cancel
Showing results for 
Search instead for 
Did you mean: 

Deleting account in the Chart of Accounts

Super Explorer ***

Deleting account in the Chart of Accounts

When I try to delete an account in the Chart of Accounts I get the following error message:
You can't delete this account because it is part of the Online Banking feature.
Is there a way to resolve it?
The account is of type and detail type Other Current Asset

4 Comments
Highlighted
Community Contributor *

Re: Deleting account in the Chart of Accounts

Yes, that is true. There are certain accounts that are linked to certain features and yes, they cannot be turned off. I know it's frustrating because you might not be using the online banking feature. However, they can be hidden by making them inactive. View your Chart of Accounts, find the account you don't want to see, at the right there is a little carrot, select "make inactive" and then you won't have to view that account. Hope that helps!

Super Explorer *

Re: Deleting account in the Chart of Accounts

I'm having the same problem and unfortunately your suggestion doesn't help. As far as I am aware, there is no such thing as actual deletion of accounts in QB Online; deactivation is the closest thing there is. Intuit confuse things by using the word "deleted" to mark deactivated accounts, but they're not deleted and can be easily reactivated.

 

And so the problem the OP is seeing -- assuming it's the same as mine -- applies when trying to make the account inactive. 

 

Furthermore, I'm seeing the problem with a brand new account; one I created myself. I then realized I didn't really need it. So it has no transactions, and if it is in some way "part of the Online Banking feature", as is claimed in the error message, then it did that itself, when I wasn't looking!

 

--

Super Explorer *

Re: Deleting account in the Chart of Accounts

Hi, did you get this resolved? I've just run into what looks like the same problem and as I explained to @smallbizkitchen, it is with a brand new account that I just created and then decided I didn't need, so I cannot see how there can be any subtle connection with "the Online Banking feature".

 

Also, bizarrely, it is actually one of two accounts I needlessly created and decided to deactivate, but it's the only one of the the two that sees the problem. The other deactivates fine. They are both very similar and were going to be used for accruing some prepaid expenses. Both are of Type, Other Current Asset; both are essentially unused having had no transactions posted to them. In fact the only difference between them that I'm aware of is in their names. One is called Prepaid Travel, and the other is called Prepaid Rent. but I can't see how the letters in the name are relevant. They could have been called Bert and Ernie and I'm pretty sure it would not have avoided the problem. Regardless, Prepaid Travel can be deactivated and reactivated fine. Prepaid Rent cannot and throws the error.

 

I'll let you know if I find a solution; please do the same?

thanks.

 

P.S. OK, I admit it. On writing the above I wondered if just maybe there could be a name dependency. It would be bloomin' annoying if there were, but Intuit have managed to squeeze no small measure of the bloomin' annoying in QBO, so I thought it was worth a try. So, I renamed Prepaid Rent as...(cough)...Ernie. No joy; calling the account Ernie made it no more deactivate-able than calling it Prepaid Rent

 

 

Community Contributor *

Re: Deleting account in the Chart of Accounts

I think it's good that you checked about the account type because that was going to be my next question.

 

Deleting accounts I don't believe is possible in QBO (someone else please chime in on this), but deactivation is. To me, it's not ideal, but at least those deactivated accounts are hidden under the bed so to speak.

 

Now back to your other problem. So you are saying you created TWO accounts, both of the same type, and one you are able to deactivate (not delete) and one you are not even able to deactivate? That seems very strange, and really does seem like a bug, unless you have double triple checked that both accounts are/were the same type, etc.

 

Maybe do a restart/clear cookies thing. Or try to access QBO from a different browser? Fingers crossed.

 

But if all else fails, just rename the account something like Z Unused account so at least it will show up on your reports at the bottom, and because you're not using it, it will have a zero balance. Perhaps in the future you will find a use for it.

 

Hope that helps.