Showing results for 
Search instead for 
Did you mean: 
Experienced Member

QB Mac 2019 Pay Sales Tax Missing

We recently went from 2013 to 2019 and went to make our first sales tax payment - but the Pay Sales Tax command is missing from the Vendor menu and if we try from another direction it points us back to the missing command. We've tried updating but are told this is the most up to date. So where did the command it's directing us to go?


Re: QB Mac 2019 Pay Sales Tax Missing

Hi there, @operapsm.


Thank you for taking the time posting in the Community. Allow me to help share some steps to ensure you're able to make your first sales tax payment in QuickBooks Mac 2019. 


First, let me commend you for downloading the QuickBooks Mac update as your initial troubleshooting step. That process is one of our basic solution for unexpected behavior like this.


Since you get the same result, let's try the next step. Let's make sure that the sales tax option is activated in the preferences.  


Here's how:

  1. Choose QuickBooks then select Preferences.
  2. On the Preferences pane, select Sales Tax
  3. Set the preferences. 
  4. Close the Preferences pane. 

After that, let's try to pay the sales tax again.


For more information about how sales tax works, I recommend checking this article, then go to page 186: QuickBooks for Mac 2019 User’s Guide.


If you need to reach out for more help, feel free to contact our phone agents. They can use the screen sharing tool to determine what's causing the issue and help you get back to business in no time. 

  1. Go to
  2. At the top right, select QuickBooks Mac Desktop.
  3. Select a topic.
  4. Click on the Get Phone Number button.

That should take care of it.


I'm just a post away if you should have any other questions about making sales tax payments. Have a great rest of your week.

Experienced Member

Re: QB Mac 2019 Pay Sales Tax Missing

Thank you. Yes, apparently in updating it dropped all that info (makes me a little concerned about what else may have been dropped). Again, thanks.