
The Accountant’s Guide to Moving Clients Online

How to convert QuickBooks Desktop data 
to QuickBooks Online

Confidently complete the migration process with these practical, step-by-step visual instructions. 
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We’re with you at every step. 

Every client’s business is unique, but the steps involved 
in moving that business online are similar. This guide will 
help you master each one so you can get your clients up 
and running—and back to business—fast.  

To help you find the exact information you need, this guide 
is divided into three sections:

Pre-migration 

Find out how to get your  
clients’ QuickBooks 

Desktop data ready for 
conversion.  

Skip to page 3.

Migration

Learn how to import data 
to QuickBooks Online in  

a few easy steps. 

Skip to page 4.

Post-migration

Discover the steps to  
follow after completing  
the data import process. 

Skip to page 6.



HOW TO CONVERT QUICKBOOKS DESKTOP DATA TO QUICKBOOKS ONLINE

2THE ACCOUNTANT’S GUIDE TO MOVING CLIENTS ONLINE

Identifying QuickBooks Desktop data for conversion

Get to know which data will and will not convert to QuickBooks Online.

Which QuickBooks Desktop files 
will convert?

 

Which QuickBooks Desktop files 
will not convert?
 QuickBooks Desktop Pro, Premier and Premier

Accountant Edition company files with more
than 500,000 targets. You will get an option
to import lists and balances only.

QuickBooks Desktop Enterprise files.

NOTE: For a comprehensive list of what does and does not convert 
into QuickBooks Online from QuickBooks Desktop click on this 
link .Have companies that will 

not convert?

You can export all their lists to an Excel or 
Intuit Interchangeable Format file, then start 
a new QuickBooks Desktop file and import the 
lists there. Then do the “full” import as normal.

All QuickBooks Desktop Pro, Premier and 
Premier Accountant Edition company files with 
up to 500,000 targets. Targets indicate 
individual line items on invoices. How to check 
for targets: press F2 or ctrl +1.

https://appcenter.intuit.com/transactionproimporter
https://appcenter.intuit.com/transactionproimporter
https://community.intuit.com/articles/1145236-import-limitations-quickbooks-desktop-to-quickbooks-online
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Pre-migration: 

Preparing QuickBooks Desktop data f or conversion 

Follow these steps for a smooth conversion. 

Help clients get familiar with QuickBooks Online.

Remember that you can only convert a QuickBooks 
Desktop company file into QuickBooks Online within 
60 days of its creation.      

The conversion is a complete overwrite of any 
information that was in the QuickBooks Online 
company beforehand. Previously entered or 
imported information will be wiped out and 
replaced by any subsequent conversions within the 
60-day period.

Accountants may choose to show clients/play 
around with the "Sample Co" available in 
QuickBooks Online Accountant, click on gear, 
“Sample Co” and explore QuickBooks Online 
features, navigation, functionality and more.

Your clients may wish to try QuickBooks Online 
while continuing to use QuickBooks Desktop for 
day-to-day transactions. If a client decides that 
QuickBooks Online is a good fit, you can help 
them convert their QuickBooks Desktop data as 
many times as they want during a 60-day 
period.

4.

QuickBooks Desktop and convert your existing 
company file to the newest format. Run the 
software update described above after updating 
your file.

• It's a good idea to backup your QuickBooks
Desktop company file before you convert your data to
QuickBooks Online. You can always restore your current
experience in QuickBooks Desktop from this backup copy.
Switch to single user mode (File > Switch to Single-user Mode).
Then, go up to File, select Backup Company and then
Create Local Backup. If you click “Backup Options,” you
can select the file location. Follow the steps and click Save
it now to complete the process.

• Run a verify from the Utilities menu. Rebuild
data if necessary by following the onscreen
instructions. (Updating the file to the latest
QuickBooks Desktop version does this
automatically.)

Run/print a Profit & Loss report and a Balance
sheet report for reference purposes.

1. Once you have a QuickBooks Online Accountant
account, you can create the QuickBooks Online
client from within that account and then proceed
with importing/overwriting the data.

2. Sign out of QuickBooks Online.

3. Next, do some work in QuickBooks Desktop:

• Before you start the conversion, make sure
your current QuickBooks Desktop software is
up-to-date.

How to update your current software:
Sign in to QuickBooks Desktop as the
administrator, click the Help Menu, select Update
QuickBooks Desktop from the drop-down and
Update Now on the next screen. Once the update
process is complete, close and reopen QuickBooks
Desktop. Take note: You must be running the
latest version of QuickBooks Desktop to convert
your company file to QuickBooks Online. If you
are using a discontinued version from 2015 or
earlier, you’ll first need to download the latest
free trial version of
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Importing data using Windows

1  Open QuickBooks Desktop.

2  Click Company > Export Company File to QuickBooks Online. 

If you still don't see this option after updating to the latest version of 
QuickBooks Desktop, check the following:

• ensure you are logged in as Admin
• ensure you are logged in under single user mode
• ensure your company file is stored locally

After completing these steps, there are two other things you can do if you still 
do not see this option:

i) Download the latest trial version of QuickBooks Desktop here.

OR

ii) Use the following steps to update QuickBooks Desktop:

a. Click Help > Update QuickBooks.

b. Select all updates in the Update Now window.

c. Click Get Updates.
(If not all updates are downloaded, the export company link
may not appear.)

d. Click Close.

e. Click File > Exit.

f. Reopen QuickBooks Desktop and finish installing the updates
when prompted. These updates may take 15+ minutes to install,
depending on how long it’s been since your last update.

Migration: 

Converting QuickBooks Desktop data  
to QuickBooks Online

Now that you’ve prepared the data, it’s time to convert it to QuickBooks Online. 
The following pages will explain each step along the way.

https://community.intuit.com/articles/1770105
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3  

6  Select the QuickBooks Online company you want to convert the 
data into. If you've already created a company file, select it here. 
Don't create a new file, as it will generate an additional subscription.

7  Click OK, got it. We’ll email you when we’re done.

If you encounter an error 
during conversion 
Because every QuickBooks Desktop company
file is different, as is the computer environment,
errors may occur. 

If you encounter an error during the conversion, 
you'll receive an email notification. We can help 
you overcome and correct these errors so that 
the import to QuickBooks Online is successful. 
The most common errors seen during conversion 
from QuickBooks Desktop to QuickBooks Online 
and their solutions can be found in this article.    

Review the migration guide for more information on the conversion 
process, tips on preparing your company data for the move, updating 
QuickBooks Desktop and maintaining a backup. Watch the video for 
a glimpse of the new experience!

4  Enter your QuickBooks Online login info, agree to the Terms of Service, 
and click Sign in.

5  Follow the moving-day checklist to ensure you are ready for the 
conversion process. The list also covers changes and differences 
in the QuickBooks Online experience. 

http://intuitaccountants.com/Qs
https://community.intuit.com/articles/1771028
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Post-migration: 

Completing and testing 
the data conversion

Follow these steps to ensure that QuickBooks Online is up and running, and that 
reports are accurate. 

Check inventory data (QuickBooks Online Plus only).

Read this if you chose “yes” to Import Inventory.  
If you chose to import inventory into QuickBooks 
Online and QuickBooks Online identifies any errors with 
inventory, the import will fail and the user will receive an 
email with instructions on how to fix the items causing 
the problem.   

If you are importing inventory, due to recalculations to 
FIFO, your Accrual Basis reports and Cash Basis reports 
will not match. 

Run reports to compare QuickBooks Desktop with QuickBooks Online.

Although your Accrual Basis reports will match in both 
products, your Cash Basis reports may not. This is because 
cash basis calculations are somewhat subjective, and there 
are several differences in how the two products calculate 
what is considered paid. 

Consult the list of reports on the right. Run these reports 
on an accrual basis for all dates in both QuickBooks 
Desktop and QuickBooks Online for comparison purposes 
to ensure that the conversion is accurate. Even if you 
generally use cash basis for your accounting, it’s necessary 
that you use accrual basis when comparing these reports. 
Only the master administrator accountant will receive the 
post migration report summary.

NOTE: The first three reports in the list below will not 
match if you are importing inventory due to recalculations 
to FIFO. 

 • Profit & Loss (Profit & Loss Standard in QuickBooks
Desktop) for all dates, accrual basis

• Balance sheet (Balance Sheet Standard in QuickBooks
Desktop) for all dates, accrual basis. Any discrepancies
in the Profit & loss report and Balance sheet report can
be found in the unmatched account balances section in
the post migration report.

• Inventory valuation summary (if applicable) for all dates

• Last bank reconciliation report

• Open invoices

• Unpaid bills

• Transaction detail for payments into undeposited funds

• Sales tax liability

• Payroll tax liabilities

You can find more information on things to check after 
converting the files here.

 

 

https://community.intuit.com/articles/1764047
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Get your clients up and running fast.

Ensure that your clients are getting the most from QuickBooks Online by 
setting up these key features.

Users and permissions 

Permissions in QuickBooks Online are similar to those 

After files are migrated, make sure to make the sales tax codes imported from QuickBooks Desktop inactive, then turn on 
the QuickBooks Online sales tax codes applicable to your province. Exception: sales tax codes from QC. View video here.

 
in QuickBooks Desktop, but they don’t allow you to  
control activity at the level of transactions. Accountant 
users can be invited from QuickBooks Online. You can 
manage your own firm’s users through QuickBooks 
Online Accountant. 

Company Settings 

Turn on account numbers, custom transaction numbers 
on sales transactions, etc. 

reconciliation reports will not come over. If it’s important 
to you to have these reports in QuickBooks Online, 
you may re-reconcile any accounts as necessary. 

If you want at least one reconciliation report to exist 
in QuickBooks Online from prior periods, and if you 
don’t need or want to create separate reconciliation 
reports for each month from these periods (or if there 
are too many months to reconcile quickly), refer to the 
last Reconciliation Detail Report for each account from 
QuickBooks Desktop and create one huge reconciliation 
period up to that statement’s end date. Leave the 
same items that are uncleared in QuickBooks Desktop 
uncleared in QuickBooks Online. 

Attachments

Attach any documents to transactions; documents 
cannot be attached to list names. 

Memorized Reports

Customize the reports you want in QuickBooks Online 
and save the customizations in My Custom Reports. 

QuickBooks Online Payments

Accept credit card payments from clients with 
QuickBooks Online Payments. Learn more about this 
here.

Take a look at the powerful third-party apps that 
integrate with QuickBooks Online and help merchants, 
such as Square.

 ü  

 ü  

 ü  

 ü  

 ü

ü

 

Templates

Create new sales templates in QuickBooks Online.

Non-posting transactions

Recreate purchase orders as required (QuickBooks 
Online Plus only). 

Reconcile accounts

The reconciliation status of all transactions in such 
accounts as Banks and Credit Cards will come over into 
QuickBooks Online (signified by an “R” beside each 
reconciled transaction). However, the related

 ü  

 ü  

 ü  

Set up payroll.

To set up payroll for Windows and Mac: 

1. In the navigation bar, click Employees.

2. In the Paid in [Year]  column, be sure each employee who
received a paycheque this year is switched to Yes.
(Employees who have not been paid in the current year will
automatically be listed as No.)

3. Click Complete payroll setup to enter and/or
verify your year-to-date payroll totals, and
employee information.

4.  Continue through the prompted flow to complete your setup,
then use Run Payroll when you’re ready to pay your employees.

http://quickbooks.intuit.ca/payments/
http://quickbooks.intuit.ca/square/
http://images.eq.intuit.com/Web/IntuitSBG/%7B59afca5a-efc7-4e2c-a859-545624fedf67%7D_QBDT_to_QBO_Migration.mp4
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Closing Date Password

If you wish to use Online Banking in QuickBooks Online, 
select Banking from the left navigation bar. There, you 
can select Add account and proceed with linking up 
various QuickBooks Online bank and credit card 
accounts with their real-life counterparts using Bank 
Feeds. 

Integrated Applications

Once the conversion to QuickBooks Online is complete, 
you may want to expand the power and usefulness  
of QuickBooks Online by taking advantage of one or 
more cloud-based apps that integrate with it seamlessly. 
These apps are available from the Apps tab on the 
left navigation bar in QuickBooks Online. Here, you 
can peruse the apps, see other users’ ratings, get more 
details, and even try them out for free. 

Sales Tax

After the conversion, all payments will need to be made 
from the Sales tax screen in QuickBooks Online using 
“Record Tax Payment.” If you record sales tax payments 
as a paid bill or cheque instead, they won’t appear in 
the Recent Payments list. 

Merging Customers

Merging customers is helpful if you’ve been using two 
similar customers and want to see those customers 
represented by a single line in your reports. The process 
of merging deletes one customer and reassigns all of its 
data to another customer. If you want to merge (and 
delete) a customer, you must delete the customer’s 
statements first.

Important: The merging process is not reversible. Merging 
is permanent and cannot be undone at a later point.

Here’s how to merge customers:

1. Choose Customers on the left navigation bar.

2. Make sure that the customers you want to merge are
at the same sublevel. If they’re not, edit one of the
customers to make it be at the same level.

3. Select the customer whose name you don’t want
to use. Note: If you have customer information
entered, it will disappear from the name you don’t
want used. Make sure you either copy the information
over to the customer’s name you’re keeping or keep
the customer with the important information.

4. Click Edit next to the customer’s name above the list
of transactions.

5. Change the customer’s display name so that it is the
same as the customer you’re merging with.

6. Click Save.

7. Click Yes to confirm that you want to merge the
two customers.

üü  

üü  

 ü 

If a closing date and password were set in QuickBooks 
Desktop, the closing date does get converted in 
QuickBooks Online; however, you will need to recreate 
the password. Review and change the date and 
password as necessary.  

üA utomatically Download Online Bank
Transactions

üü  
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Now you have the knowledge you need to skillfully convert clients’ QuickBooks Desktop 
files  to QuickBooks Online. Don't forget to take your QuickBooks Online certif ication. 

    :enilnO skooBkciuQ fo gnidnatsrednu ruoy nepeeD

.

Payroll Summary Report Payroll Details Report

File Manager QBOA Dashboard (all invited staff can work)

Reports > Filter Reports > Lists

Statement Writer Management Reports (not as robust but able to build a report)

Items List Products & Services List

Preferences Company Settings

Memorized Transactions Recurring Transactions

Memorized Reports My Custom Reports

Audit Trail Report Audit Log Report (also tracks when users log in and out)

Credit Card Charge Credit Card Expense (use the Expense Form to create this entry)

Class Tracking Class AND Location Tracking (QuickBooks Online Plus only)

Desktop to Online translation

QuickBooks Desktop QuickBooks Online




