cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Experienced Member

2019 QuickBooks for Mac compatibility with Mojave 10.15

If I buy 2019 QuickBooks for Mac, will it run on a new Mac running Mojave 10.15 which runs only 64 bit programs?
Solved
Best answer 08-08-2019

Accepted Solutions
Moderator

Re: 2019 QuickBooks for Mac compatibility with Mojave 10.15

Welcome to the Community, PipLaSalle.

 

Yes, QuickBooks Desktop for Mac 2019 is compatible with at least macOS 10.14 (Mojave) and higher version, including 32 and 64 bit.

 

You can check out this article that will provide more information: System requirements for QuickBooks 2019 and Enterprise Solutions 19.0.

 

I'm also linking our QuickBooks for Mac 2019 User's Guide to learn some various tasks within the program.

 

Please let me know if you have further questions. I'm always happy to step in and lend a hand. Have a great day.

1 Comment
Moderator

Re: 2019 QuickBooks for Mac compatibility with Mojave 10.15

Welcome to the Community, PipLaSalle.

 

Yes, QuickBooks Desktop for Mac 2019 is compatible with at least macOS 10.14 (Mojave) and higher version, including 32 and 64 bit.

 

You can check out this article that will provide more information: System requirements for QuickBooks 2019 and Enterprise Solutions 19.0.

 

I'm also linking our QuickBooks for Mac 2019 User's Guide to learn some various tasks within the program.

 

Please let me know if you have further questions. I'm always happy to step in and lend a hand. Have a great day.