cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Level 1

Quickbooks 2012 For Mac on MacOS Hight Sierra Issues. I had my old computer , so i got new Mac with High Sierra OS, so i installed the quickbooks 2012 for mac.

 
Solved
Best answer 12-10-2018

Best Answers
Highlighted
Level 7

Quickbooks 2012 For Mac on MacOS Hight Sierra Issues. I had my old computer , so i got new Mac with High Sierra OS, so i installed the quickbooks 2012 for mac.

The 2012 program is not compatible with High Sierra. Only the 2015 & the 2016 programs are compatible with High Sierra.

View solution in original post

2 Comments
Highlighted
Level 7

Quickbooks 2012 For Mac on MacOS Hight Sierra Issues. I had my old computer , so i got new Mac with High Sierra OS, so i installed the quickbooks 2012 for mac.

The 2012 program is not compatible with High Sierra. Only the 2015 & the 2016 programs are compatible with High Sierra.

View solution in original post

Highlighted
Level 8

Quickbooks 2012 For Mac on MacOS Hight Sierra Issues. I had my old computer , so i got new Mac with High Sierra OS, so i installed the quickbooks 2012 for mac.

You can download a trial version of 2016 from <a rel="nofollow" target="_blank" href="http://www.qblittlesquare.com">www.qblittlesquare.com</a>.  You can use that trial for 30 days without purchasing.

Need to get in touch?

Contact us