cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

QuickBooks 2014 Mac OS Compatibility Error

We've been using Quickbooks 2014 for a few years and I recently updated my Mac OS to High Sierra, it is giving me an error message that Quickbooks 2014 is no longer compatible with this verson of Mac OS. What do I need to do to get up and running agian. Update to the latest release or download a new version? 

 

Thank you for your help.

 

(Title edited by moderator for clarity)

Solved
Best answer 12-28-2017

Accepted Solutions
Established Community Backer ***

Re: Compatibility Error

Hi there,

Any Quickbooks version which is 2014 edition or older than that is no longer supported by Quickbooks. The best option would be to buy the latest version of Quickbooks. In your case you could follow this link -

 

https://quickbooks.intuit.com/mac/

 

12 Comments
Content Leader

Re: Compatibility Error

Hi LeatherworksMN,

 

Welcome to the Community. I'm glad to offer my assistance.

 

QuickBooks 2014 has reached the end of its useful life and does require replacement at this time. However, QuickBooks 2016 would work great with High Sierra.  The replacement program will be your choice. The oldest version that would work with High Sierra would be 2016 but any release thereafter would work as well.

 

I hope this helps get you back on track. Please let me know if you have any other questions.

 

 

Established Community Backer ***

Re: Compatibility Error

Hi there,

Any Quickbooks version which is 2014 edition or older than that is no longer supported by Quickbooks. The best option would be to buy the latest version of Quickbooks. In your case you could follow this link -

 

https://quickbooks.intuit.com/mac/

 

Not applicable

Re: Compatibility Error

HI.  I updated to Mac OS High Sierra before I knew there would be a problem with Quickbooks.  Now my Quickbooks wont open for me to transfer to the online version.  My Accountant emailed me her updated copy of my business but it wont load on the web based quickbooks becuase there is not an area for all files at one time.  I found an older macbook and uploaded my older version QB but the account email file still wont load becuase it say the QB was created in a different version.  These are the only ones that i have had so I am not sure why this is happening.  Can you help? I was on the phone for an hour and half today with intuit to no avail.

Established Community Backer ***

Re: Compatibility Error

Hi,

Welcome to the community.

It would be very helpfull if you could tell us the version and edition of QuickBooks you are using.

 

Not applicable

Re: Compatibility Error

My situation is similar. Does this mean I need to switch to the online version of quickbooks? If I buy that, will it upload from my 2014 quickbooks?

Not applicable

Re: Compatibility Error

Where can I find Quickbooks 2016? Don't see it at the QB website, only online versions...

Established Community Backer ***

Re: Compatibility Error

Hi SteveByers,

 

Just to let you know that you could place an order for QuickBooks Mac by calling up Intuit. 

 

You could call up the below mentioned number and place an order for QuickBooks Mac 2016 edition.

 

1-800-224-0952

 

As for upgrading co file to the latest version please make a copy before you try anything. Mac automatically backs up files from time to time. You can run a search for them. They are .qbb files. 

 

The best thing would be to call up QuickBooks Helpline numbers and give remote access to one of the technicians over there and let them do it for you. Remember such Intuit services are free of charge.

Not applicable

Re: Compatibility Error

me too

Not applicable

Re: Compatibility Error

HI!I have a similar issue,buthave Quickbooks 2014 on my older desktop, want to put a version on my newer laptop running High Sierra, but want be able to import my 2014 files/list/invoices/etc. Is that doable? with which version(s) of qb ?

 

Thanks!

Jim

 

QuickBooks Team

Re: Compatibility Error

Hello there, @xylojim.

 

I’m here to help ensure your QuickBooks 2014 company files works well with the latest version of QuickBooks Mac.

 

If you’re trying to restore your 2014 company files using the latest QB Mac 2019 version, yes, you can certainly do so. Just make sure to secure a back-up copy of your company file before restoring to the latest version. By doing so, you’ll always have an intact company file to use in the event you encounter errors during the restoration process.

 

On the other hand, you can try using the QuickBooks Desktop for Mac Trial version first so you can explore the new features available on the new version.

 

Here are the minimum requirements for this new QuickBooks version:

  • At least macOS 10.12 (Sierra); supported by macOS 10.13 (High Sierra), macOS 10.14 (Mojave)
  • Intel processor, Core 2 Duo or higher
  • Multiuser Server: Intel Core 2 Duo or higher processor to run server
  • 2 GB RAM (4 GB RAM recommended)
  • 250 MB of available disk space
  • CD/DVD drive or Internet connection for downloaded installation
  • Printer: 100% Macintosh-compatible printer, if you plan to print invoices, checks, deposit slips, lists, purchase orders, mailing labels, reports, or graphs
  • Checks: Use Intuit Checks if you plan to print checks. Canadian Image Ready Checks are not supported
  • Product registration required

To install, here’s how: 

  1. Visit this link: Download QuickBooks Desktop for Mac 2019 30-day trial.
  2. Select your Product and Version.
  3. Click Search.
  4. Click Download.

Please follow these steps on how to install QuickBooks:

  1. Run your downloaded QuickBooks 2019.
  2. Click Yes pop-up messages.
  3. Select Next to begin the installation.
  4. Click the I accept the terms in the license agreement box and click Next.
  5. Enter your License and Product numbers, then select Next.
  6. Continue the prompts to finish the installation process and restore your company file.

Once the trial version is consumed, I suggest contacting out to our Customer Care Team to further process your order for the regular QuickBooks Desktop for Mac.

 

Here’s how you can contact us:

  1. Visit: https://help.quickbooks.intuit.com/en_US/contact.
  2. Choose your QuickBooks Product.
  3. Select your QuickBooks version.
  4. On the Contact Us page, click a topic.
  5. Click on the Get Phone Number button to see the support number.

That should do it! Feel free to drop a comment below if you have follow-up questions about upgrading your QuickBooks company file to the latest version. I’m always here to help.

Not applicable

Re: Compatibility Error

hello

I'm using QuickBooks  pro 2014 and I have an error code [removed]. Can you help to fix it please .

Moderator

Re: Compatibility Error

Hey there, otpsprotection.

Allow me to take over and get this resolved quickly.


Let's try to verify and rebuild your data. The data verification process in QuickBooks is a tool that examines the health of your QuickBooks company data file.


To Verify Data:

 

  1. Choose Window at the top, then Close All.
  2. Choose File.
  3. Click on Utilities.
  4. Choose Verify Data.

To Rebuild Data:

  1. Choose File.
  2. Click on Utilities.
  3. Click Rebuild Data.
  4. You will receive a warning message to backup your company file, press OK.
  5. Click OK when you get the message "Rebuild has completed".

You can check this recommended article for more details: https://community.intuit.com/articles/1774819-verify-and-rebuild-data-in-quickbooks-desktop.

 

Let me know how it goes, I'll be around to help. Have a good one.

Need to get in touch?

Contact us