cancel
Showing results for 
Search instead for 
Did you mean: 
EB2020
Level 2

Quickbooks Enterprise 2020 - Setting up/linking UPS account

After the 2020 install I am not able to link our UPS account.   When trying to ship a UPS order  -  In the background I get a message that says "Retreiving UPS End-User Licence Agreement"   After about a minute the system times out and throws a "XPost: General Error.   I am then directed to another screen called "UPS Developer Kit Licence and Registration Wizard"  I am prompted to provide a My.Shipping Manager.com credentials including a Username & Password.   Nothing works and there are not options to reset a password.

 

I was able to easily setup stamps.com and Fedex so it seems like a bug with UPS setup.   I have had a UPS account for 10 years.

 

Have also spent 2 days with QB support and have uninstalled and reinstalled the 2020 update with no success.

 

Is this a QB problem or a UPS problem?

Solved
Best answer April 08, 2020

Best Answers
MirriamM
Moderator

Quickbooks Enterprise 2020 - Setting up/linking UPS account

Thanks for reaching out to the Community, @EB2020.

 

I appreciate you contacting our Customer Care team about the UPS problem.

 

Normally, you'll encounter an error when the Shipping Manager account is damaged. I have some troubleshooting steps that you can follow to get back feature working smoothly like you'll have to delete the account and create a new one.


Here’s what you'll need to do:

  1. Go to File at the top menu bar, then select Shipping.
  2. Choose Shipping Options, and select Settings.
  3. Click on Delete Account.

Once done, set up the new account. Here's how:

  1. In your QuickBooks company file, go to File at the top.
  2. Select Shipping, then choose Ship UPS Package.
  3. Enter your account information.
  4. Make sure to read the End User License Agreement, and choose I Agree to terms and conditions.
  5. Click Next.
  6. Configure your printer settings, then select Next and Finish.

If done, you can now process a shipment. For more detailed information on how the Shipping Manager can help process shipments and labels, check out these articles:

If there's anything else you need help with, visit the Community again. I'd be more than happy to assist. Take care.

View solution in original post

7 Comments
MirriamM
Moderator

Quickbooks Enterprise 2020 - Setting up/linking UPS account

Thanks for reaching out to the Community, @EB2020.

 

I appreciate you contacting our Customer Care team about the UPS problem.

 

Normally, you'll encounter an error when the Shipping Manager account is damaged. I have some troubleshooting steps that you can follow to get back feature working smoothly like you'll have to delete the account and create a new one.


Here’s what you'll need to do:

  1. Go to File at the top menu bar, then select Shipping.
  2. Choose Shipping Options, and select Settings.
  3. Click on Delete Account.

Once done, set up the new account. Here's how:

  1. In your QuickBooks company file, go to File at the top.
  2. Select Shipping, then choose Ship UPS Package.
  3. Enter your account information.
  4. Make sure to read the End User License Agreement, and choose I Agree to terms and conditions.
  5. Click Next.
  6. Configure your printer settings, then select Next and Finish.

If done, you can now process a shipment. For more detailed information on how the Shipping Manager can help process shipments and labels, check out these articles:

If there's anything else you need help with, visit the Community again. I'd be more than happy to assist. Take care.

View solution in original post

EB2020
Level 2

Quickbooks Enterprise 2020 - Setting up/linking UPS account

Thank you for trying to help...

 

I tried that but it does not give me the option to delete the account.   As soon as I select "Settings" as you describe below quickbooks starts right into "Retrieving UPS End-User Licence Agreement" and then I get the XPost: General Error message.

 

 

MaryLurleenM
Moderator

Quickbooks Enterprise 2020 - Setting up/linking UPS account

Hello there, EB2020,

 

You might want to check if there's a firewall that hinders the connection between QuickBooks and your UPS account.

 

If the error persists, I recommend contacting our QuickBooks support. They have the tools to check your account and will be able to assist you further.

  1. Go to Help, then select QuickBooks Desktop Help.
  2. Select Contact Us.
  3. Enter your concern, then select Continue.
  4. Select Start messaging.

Please note that our support hours is adjusted to 6 AM-6 PM PT Monday-Friday.

 

Stay in touch with me if you have other concerns.

EB2020
Level 2

Quickbooks Enterprise 2020 - Setting up/linking UPS account

This has now been resolved.   Thank you!

amacrae
Level 1

Quickbooks Enterprise 2020 - Setting up/linking UPS account

Can I ask how this was resolved as I am having the same issue

MaryLandT
QuickBooks Team

Quickbooks Enterprise 2020 - Setting up/linking UPS account

Allow me to step in and provide some steps to fix the issue about linking your UPS account to QuickBooks, amacrae.

 

You can follow the process provided by my colleague in this thread. And, if the same issue persists, here is the next solution you can perform:

 

  1. Close QuickBooks Desktop.
  2. Rename the following Shipping Manager folders to ShippingManagerOLD:
    Location:
    • C:\Program Files (x86)\Common Files\Intuit\ShippingManager
    • C:\Users\[WindowsUserName]\AppData\Roaming\Intuit\ShippingManager
  3. Repair the QuickBooks installation.
  4. Open QuickBooks Desktop.
  5. Go to File, then Shipping.
  6. Select [Courier] Shipping Options, then Settings.
  7. Re-enter your shipping account information. Shipping Manager should now work as expected.

You can visit again these articles for more details:

Stay in touch on how this goes by commenting below. I'll be around until you're able to connect your UPS account to QuickBooks.

krydayton
Level 1

Quickbooks Enterprise 2020 - Setting up/linking UPS account

Hi @EB2020 We are having similar issues. Can you confirm what your resolution was? Was it the firewall?

Sign in for the best experience
Ask questions, get answers, and join our large community of QuickBooks users.
Sign In / Sign Up

Need to get in touch?

Contact us