cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

TLS 1.2 error continues after .net and TLS 1.2 operations are confirmed.

I'm still receiving the warning due to my operating system even though it is now compliant. Will the system continue to work once the TLS 1.2 is implemented. Operating system is Windows Server Datacenter - Copyright 2007 - Service pack 2

23 Comments
Community Contributor *

Kent, when are you receiving the warning, and what does i...

Kent, when are you receiving the warning, and what does it say exactly?  What do get exactly if you type winver at a command prompt? I may be able to give you a little more help. Thanks!
Not applicable

I get the warning when I first open the program.  The ver...

I get the warning when I first open the program.  The version is 6.0.6002. Windows Server Datacenter.
Community Contributor *

When are you receiving the warning, and what does it say...

When are you receiving the warning, and what does it say exactly? There are several factors that cause the message to come up, and the specific wording will give me a direction to go in. Thanks!
Not applicable

I am getting error message even though I have followed al...

I am getting error message even though I have followed all the items listed to "fix" the issue as well.
Moderator

Hi, kent, Let me help you get rid of the error TLS 1.2 er...

Hi, kent,

Let me help you get rid of the error TLS 1.2 error and get you back on track.

The default browser for QuickBooks is IE, you'll need to configure your IE settings to avoid TLS error.

Here's how:

  1. Click on Tools and then Internet Options.
  2. On the General tab, select Delete.  Select Temporary Internet files and click Delete. (Note - do not select to delete cookies.)
  3. On the Connections tab, select LAN settings.
    a. Mark the checkbox next to Automatically Detect Settings.
    b. Make sure Proxy servers are blank unless you use one.
    Note: You may need to check with your IT administrator.
    c. Choose Ok twice.
  4. On the Advanced tab, go about 3/4 of the way down the list.
    a. Make sure both SSL 2.0 and SSL 3.0 are marked.
    b. If marked, please clear the box next to Check for publisher's certificate.
  5. On the same Advanced tab, scroll down towards the bottom.
    a. Make sure TLS 1.2 is not checked.  If marked, clear the checkbox.

You may want to check this article for additional information: https://community.intuit.com/articles/1436605

Feel free to get back in touch with me if you have other concerns.

Not applicable

Unfortunately, I have another application that requires T...

Unfortunately, I have another application that requires TLS 1.2 so I can't take it away. My understanding is that by May 31, 2018 that QuickBooks requires TLS 1.2 for communication for Online Banking. Turning it off now, is just making a problem go away temporarily. How do you solve the TLS 1.2 error message within QB Desktop Pro when the TLS 1.2 is working correctly.
Moderator

Hi @kent, Thank you for getting back to me. I would sug...

Hi @kent,

Thank you for getting back to me.

I would suggest you contact our QuickBooks Desktop Support to help you set up the TLS 1.2.

Here's how you can contact us:

1. Go to: <a rel="nofollow" target="_blank" href="https://help.quickbooks.intuit.com/en_US/contact">https://help.quickbooks.intuit.com/en_US/contact</...>.
2. If asked, choose your QuickBooks Product.
3. Select your QuickBooks version.
4. On the Contact Us page, click a topic.
5. Click on the Get Phone Number button to see the support number.
Not applicable

this wasn't helpful at all!!!

this wasn't helpful at all!!!
Community Contributor *

Unfortunately, IntuitRoseMarjorie answer is completely th...

Unfortunately, IntuitRoseMarjorie answer is completely the opposite of what it should be.

What would be helpful to know is when are you receive the warning, and what does it say EXACTLY? There are several factors that cause the warning messages to come up, and the specific wording will help me offer you a direction to go in. Thanks!
Not applicable

The error is...  Operating System. Your operating system...

The error is...  Operating System. Your operating system does not support TLS 1.2. Upgrade your operating system to allow QuickBooks to use TLS 1.2. I'm using Windows 2008 Server - 32 bit. The system supports TLS 1.2 because I'm using it for another application that is working fine.
Community Contributor *

Please look at the answer I posted.  You may need to expa...

Please look at the answer I posted.  You may need to expand it to see it.  I tried commenting here, but Intuit has some automatic means of deleting it.  Maybe they are not pleased with my answer?
Not applicable

So you are advising people to REDUCE their security in th...

So you are advising people to REDUCE their security in their browser in order to fix your security issue?  This seems counter intuitive and I would think it would open Intuit up to litigation since you are telling people to make themselves more vulnerable to attack.  Maybe you could fix the issue with your software, that might be a good starting place.
Community Contributor *

For whatever reason, Intuit keeps deleting this answer if...

For whatever reason, Intuit keeps deleting this answer if I put the actual path to the QBW.ini file:

Even though I have the TLS 1.2 option in Internet Explorer 9/Windows Vista (same holds true for version is 6.0.6002. Windows Server Datacenter) and it works on other sites, it will not satisfy QuickBooks Desktop (Enterprise 16, in my case). So I just turned the reminder off in the QBW.ini file and made it "read only". I get a warning message, but no more nagging.

The file is located: C drive, ProgramData (folder), Intuit (folder), QuickBooks Enterprise Solutions 16.0 (your version name may be different) (folder),  QBW.ini (file).

In the file I located and set the following:

[QBPROACTIVE_ALERT_STATE]
QB_TLS_COMPLIANCE=0 <------ 0

[QBPROACTIVE_ALERT_VISIBILITY]
QB_TLS_COMPLIANCE=4 <------- 4

Saved file. Right clicked on it, went to Properties, and marked it "Read Only", and applied.

One minor warning when I start the program, but, no more nagging. Plus it makes your Reminder Flag useful again.

QuickBooks (Enterprise 16 in my case) is basing the TLS 1.2 non-compliance on Windows version and MAYBE Internet Explorer version (it wants 11), even though IE 9 can be made to handle TLS 1.2, and mine does. What is Intuit going to do when Windows moves to Edge and Micro$oft stops supporting IE 11? Three guesses, and the first two do not count!

I am sure I will upgrade my PC eventually (I already had to replace 3 because of QuickBooks). Not so sure I will upgrade QuickBooks Enterprise 16 when it ceases to function.

Not applicable

I am receiving a TLS 1.2 validation failed error

I am receiving a TLS 1.2 validation failed error

Community Contributor *

Which version of Windows are you using, gsambolin?

Which version of Windows are you using, gsambolin?
Not applicable

Windows 10, just got a brand new system

Windows 10, just got a brand new system
Not applicable

I have the same issue and using Windows 10 - an answer to...

I have the same issue and using Windows 10 - an answer to solve this problem would be appreciated!
Community Contributor *

The original question was for Windows Sever Datacenter, w...

The original question was for Windows Sever Datacenter, which is the sever version of Windows Vista. Did you try searching "Operating System, Internet Explorer and .Net framework requirements for QuickBooks Desktop 2015 and later" on this Learn and Support site?  It goes through pretty thoroughly the things that need to running correctly for TLS 1.2 to work and to make the warning messages go away.

I tried to leave a link to the page, but Intuit usually erases it (why, I don't know), and then locks me out of the site for 24 hours.
Not applicable

Re: TLS 1.2 error continues after .net and TLS 1.2 operations are confirmed.

I too verified everything was correct but the warning would not go away. I did a repair of the program from the control panel and the tls warning went away.  This is confirmed on three machines so far. 

QuickBooks Team

Re: TLS 1.2 error continues after .net and TLS 1.2 operations are confirmed.

Thanks for that information, rdiddy. 

 

This will surely help other users who'll come across this thread. 

 

The Community Team is always here if you need more help!

Not applicable

Re: TLS 1.2 error continues after .net and TLS 1.2 operations are confirmed.

Can you elaborate on what you mean by "I did a repair of the program from the control panel "  What control panel?  Windows control panel?  Or is this something from within Quickbooks?

 

I have a customer with this issue and I am not going to turn off TLS 1.2 and I am not going to turn on TLS 2 & 3 as they are insecure.  I would like to find an actual fix to this issue and not by breaking security protocols.

 


@rdiddy wrote:

I too verified everything was correct but the warning would not go away. I did a repair of the program from the control panel and the tls warning went away.  This is confirmed on three machines so far. 


 

Moderator

Re: TLS 1.2 error continues after .net and TLS 1.2 operations are confirmed.

Good day, Kentw.

 

By running a repair on your QuickBooks, you are replacing all damaged installation files of the software. Additionally, this usually resolves corruption issues, such as being unable to open the file or preventing you from performing common tasks.

 

To repair QuickBooks, you can refer to these steps:

  1. On your computer, click on the Windows Start menu.
  2. In the search field, enter Control Panel.
  3. On the Control Panel page, choose Programs and Features or Uninstall a Program.
  4. Select QuickBooks Desktop and Uninstall/Change.
  5. Follow the onscreen instructions to uninstall the program.

Just in case you need help in troubleshooting QuickBooks Desktop and Internet Explorer, take time to read this article: Verify and Troubleshoot QuickBooks Desktop and Internet Explorer settings.

 

Let me know how it goes in the comment section. I'll be here to keep helping. Have a great day.

Not applicable

Re: TLS 1.2 error continues after .net and TLS 1.2 operations are confirmed.

If anyone on a Windows 10 laptop using QuickbooksPro 2016 Desktop version is being tortured by this error, this worked for me.

I don't use Internet Explorer anymore , don't even have it loaded on my laptop. You can still set Windows Internet Options to TLS 1.2. I checked that Firefox was set to minimum 1.2 in about:config , and unchecked the lower protocols in advanced proxy settings in Windows Internet Options . Then I ran QuickBooksPro once as an administrator and the error went away.

I am not any sort of IT person, just a self-employed person. If you search the name of the browser you use and "TLS 1.2 settings" you will be able to find  specific instructions re: what to do in Firefox about:config and Msft Internet Options to set TLS protocols.

And, yes, I feel like Quickbooks is throwing a bit of BS error messages at QB2016 desktop users with very simple accounting requirements to try to get us to upgrade to the monthly versions or pay $399 for desktop software that likely will be much cheaper in a year.

Need to get in touch?

Contact us