cancel
Showing results for 
Search instead for 
Did you mean: 
CH55
Level 1

Logo won't load for company or on invoices.

Its a PNG, small size, and I tried a private window, through the app on my desktop and online.

I get to the save button and when you click save nothing happens.  Any help would be greatly appreciated.

1 Comment 1
MorganB
Content Leader

Logo won't load for company or on invoices.

Hey there, CH55.

 

Thanks for reaching out for support here in the Community. I'm here to provide some additional info so you're able to upload your company logo.

 

In addition to the steps you've tried so far, it's always a good idea to clear the browser cache. Sometimes the cache can get full of older stored data, which can potentially cause viewing and performance errors within the system. Clearing it will get everything back up and running smoothly. For example, here's how you'd do this in Chrome:

 

1. Click the three vertical dots in the top right corner.

2. Select More Tools, then Clear Browsing Data.

3. Change the time range to All Time.

4. Only check Cached images and files.

5. Click Clear data.

 

This article provides similar steps for other browsers: https://community.intuit.com/articles/1771586.

 

One other method to fix the problem with the logo not uploading is to save it as .jpg. You can do this by opening the logo in Microsoft Paint, choosing Save As, then saving with a different file name and as a .jpg. The following link covers adding, customizing, or removing logos on sales forms.

 

Please don't hesitate to reach back out if you have any other questions. I'll be here to help.

Sign in for the best experience
Ask questions, get answers, and join our large community of QuickBooks users.
Sign In / Sign Up

Need to get in touch?

Contact us