cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Level 1

If I received a payment for a specific invoice via QB payment from a client but the QB did not record it, how do fix that?

 
3 Comments
Highlighted
Community Champion

If I received a payment for a specific invoice via QB payment from a client but the QB did not record it, how do fix that?

Didn't record it? Did it clear your bank? Or it posted as unapplied?

 

Or it posted to the place it should post to begin with - in the For Review section - to be reviewed and matched

 

As long as you are certain it was paid and not reversed go ahead and record it. +New Transaction>Receive Payment

Highlighted
Level 1

If I received a payment for a specific invoice via QB payment from a client but the QB did not record it, how do fix that?

I invoiced the client online. The client paid the invoice online into QB, corresponding to that invoice sent to her. I received the email saying the payment was made. However QB did NOT record that payment (only that one, all others were fine) corresponding to the invoice (when it was supposed to). So the invoice reads as unpaid, which is not true. When I tried to apply the payment myself ("Receive Payment"), for the method of payment I clicked on "QB payment credit card" (after all she paid with her card), and in turn they ask for the credit card information! I don't have it because the CLIENT paid herself. So what do I do here? Ask her for her CC info? Why? She paid it already!

 

Not only that, but when I look at the QB Deposits, it shows that there was a deposit made for that correct invoice. So why is the invoice still reading as unpaid?

 

That's the problem. All I need is for her invoice to be classified as paid, and then the problem is solved.

 

How do I do that?

 

Many thanks

 

Joseph

 

Highlighted
Moderator

If I received a payment for a specific invoice via QB payment from a client but the QB did not record it, how do fix that?

@FastMeasures Thank you for clearing that up.  

 

QuickBooks Online automatically applies payments to the invoice the payment was made from. If you open the deposit from your register, it should list the payment that was recorded. If you open that payment, it should have a check mark beside the invoice it was applied to.

 

Please check to see if the correct invoice is selected.  If you see the correct invoice applied to the payment I advise to contact support to look further into the issue.

 

This link will take you to the QuickBooks support page, where you can select your service and the proper contact channel: Contact Support

 

Let me know if you have additional questions.

 

 

Need to get in touch?

Contact us