cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Level 1

Profit & Loss by Class detail

When I run the report Profit & Loss by Class, my report looks great. I see everything I should. However, when I click on a specific number to find the transaction "behind" it, I am taken to the transaction Detail by Account report and it is blank - it should contain all the transactions that make up the total on the P&L Class report, but it is blank, not showing any transactions. Is there a way to correct this?

4 Comments
Highlighted
Anonymous
Not applicable

Profit & Loss by Class detail

Great day, OTB VA,

 

I can help you get past the issue you're getting with your Transaction Detail By Account report.

 

First, let's try opening a QuickBooks sample company file and pulling the same report. If it works, use you'll need to run the Verify/Rebuild Utility Tools to identify and resolve data damages in the company file. Here's how to do that:

 

To Verify Data:

  1. Go to the File menu.
  2. Select Utilities.
  3. Choose Verify Data.

To Rebuild Data:

  1. Go to File.
  2. Choose Utilities.
  3. Click on Rebuild Data.

You may refer to this article to know more about the process: Resolve data damage on your company file.

 

That should do it, OTB VA. Please let me know if you need further assistance with your reports. I'll make sure to get back to you whenever you need me. Have a great day!

Highlighted
Level 1

Profit & Loss by Class detail

Thank you for your response. QB said that there were no mistakes in the data, it was all okay. So that is not the issue.

 

If I run the report, P&L by class, but do NOT filter a class, the report works fine - I can click on a number and it will pull up the data behind it. However, when I add the filter to look at the class I want to, the report looks great, but when I click on a number, there is no data behind it. It's very frustrating.

 

Any additional advice?

Highlighted
Level 1

Profit & Loss by Class detail

I verified the data and QB said that everything looks good, noting to repair. So, that is not the issue.

 

If I run a P&L report by class without filtering a specific class, I can click on any numbers on the report and it gives me the data behind it. However, once I filter the report to include only the class I want to see, the report looks correct, but when I click on a number to drill down to the detail, none of the detail populates. It's very frustrating.

 

Any further advice?

Highlighted
QuickBooks Team

Profit & Loss by Class detail

Hello there, @OTB VA.

 

Thanks for getting back to us. I'm here to guide you to the right support so you can get the help you need. 

 

I appreciate you for following the steps provided by my colleague Jen_D just to resolve this issue. Since the issue still persists, I encourage you to get in touch with our QuickBooks Desktop Technical Support Team. They have additional tools to pull up your account and investigate this further. 

 

You can contact our phone support by following the steps below: 

  1. Click this link: https://help.quickbooks.intuit.com/en_US/contact.
  2. Select version of QuickBooks, click Contact Us.
  3. Type-in Technical Support on the search bar. 
  4. And click Get the Phone number below. 

Please let me know how it goes by clicking the Reply button below. I'm always here to help you out if you have any other concerns. Have a good one. 

Need to get in touch?

Contact us