cancel
Showing results for 
Search instead for 
Did you mean: 
galvanicmac
Level 2

QBO is reporting "Delivery Errors" but I know that these invoices were delivered because they were shown "read" and they were paid! Are these false alarms a known issue?

 
2 Comments 2
Jen_D
Moderator

QBO is reporting "Delivery Errors" but I know that these invoices were delivered because they were shown "read" and they were paid! Are these false alarms a known issue?

Hi there, @galvanicmac,

 

I've check my resources and haven't found similar issues reported at the moment. If you're experiencing any unexpected behavior in QuickBooks, let's troubleshoot it by trying a new browser or a private window.

 

Doing this will help us catch if the issue is caused by the data in the cache. If you want to try it on an Incognito page, use the following shortcuts depending on the browser you're using:

Google Chrome: press Ctrl Shift N  
Mozilla Firefox: press Ctrl Shift P
Safari: press Command Shift N

 

If it doesn't give you the Delivery error on the new window, clear the browser's cache to start with a clean slate.

 

However, if the same issue persist, I highly recommend contacting us directly. Our representatives can create an investigation for this error.

 

Please note that we have updated our support hours due to the ongoing pandemic. We are available from 6 AM-6 until PM PT weekdays, and will resume normal hours as soon as possible.

 

To contact us:

 

  1. Sign in to your QBO account.
  2. Click the (?) Help icon in the upper right-hand corner of the Dashboard.
  3. From there, select the Contact Us button and enter your concern in the description box.

  4. Once done, select Start a chat or Get a callback option.

Let me know how it goes in the comment. You can always contact me anytime for additional support. Have a good one!

MJCambridge
Level 1

QBO is reporting "Delivery Errors" but I know that these invoices were delivered because they were shown "read" and they were paid! Are these false alarms a known issue?

I have resolved this issue after an online chat with Support.

In my case it appears that it all stems from trying to send copy invoices to another email address, whether by ticking the 'Email me a copy at' box (Gear Icon/Account & Settings/Sales/Messages (Default email message sent with sales forms), or by entering an email address there in either the Cc or the Bcc box. Even ticking the 'Send me a copy' box in the Send dialog has the same effect.
I have given feedback about this so hopefully someone at QuickBooks will get this corrected sometime!

Need to get in touch?

Contact us
Sign in for the best experience
Ask questions, get answers, and join our large community of QuickBooks users.
Sign In / Sign Up