Level 8

Install

We can't update 2014 or earlier to work with a new OS because of how the revenue was recognized in those years. For 2015 and 2016 we are allowed to update to the new OS and are doing so.  2016 also includes many new features (we just released a bunch of them) and something people tend to forget is that every year we make the program more robust and safer via bug fixes, better tools ,etc.   The $149 I believe is promotional pricing given out to help with the issue.