QuickBooks Team

Reports and accounting

Thanks for sharing a screenshot of your Preferences window, Mellane.

 

Let's try a couple more troubleshooting steps to have the Billable box stays unchecked. Here's how:

 

  1. Go back to the Preferences window and temporarily check the Mark all expenses as billable box.
  2. Click OK, then click OK once again.
  3. Close and re-open QuickBooks and log back in to the company file.
  4. Re-open the Preferences window and uncheck the box one more time.
  5. Make sure to click OK whenever prompted that "QuickBooks must close all its open windows to change this preference".

Once saved, create a sample vendor invoice and check if the Billable box remains unchecked when adding a customer job.

 

If you're getting the same result, proceed to updating QuickBooks to the latest release, then toggle the settings in the Preferences window afterwards.

 

Follow this article on how to update QuickBooks: Update QuickBooks Desktop To The Latest Release.

 

Please add another reply below if you require additional help with this. You can also revisit the Community if you need anything else.