Level 1

Shipping not required on my invoices but some not all invoices already have the boxes on screen even though it is unchecked for the customer, how do I remove shipping?

 
QuickBooks Team

Transactions

Hello there, @info824.

 

You can edit the invoice template and remove the shipping information. Let me guide you how.

  1.  Go to the Gear icon.
  2. Select Custom Form Styles.
  3. Locate your invoice template and click Edit.
  4. Choose the Content tab and select the Header section.
  5. Uncheck Shipping under the Display section. 
  6. Hit Done.

 For more detailed steps about customizing invoices, you can check out this article: Customize invoices, estimates, and sales receipts in QuickBooks Online.

 

Also, you can import your own from styles in your QBO account. Feel free to check this article for the detailed steps: Import custom form styles for invoices or estimates.

 

If there's anything else that I can help you with, please let me know in the comment section down below. I'll be always around ready to help.

Level 6

Transactions

This appears to be a (new) bug.

It's been happening on & off for the last few weeks.

(Coincidentally, the Message Box Size bug seems to have been cured about the same time)

 

I have Shipping switched OFF in Accounts & Settings > Sales > Sales Form Content.

I have Shipping unchecked in Custom Form Styles > Content > Header.

I have Shipping unchecked in Invoice Edit > COG > Choose What You Can Use.

 

Yet, sometimes, the Shipping Fields appear.

As far as I can tell the behaviour is random.  It happens on different PCs using different browsers - both before & after a cache clearout as well as incognito/private browsing modes.

 

The shipping fields can appear when viewing an old invoice on screen (in edit mode, I use a docx template so the fields won't carry through to the print/pdf invoice).

The shipping fields can appear when creating a new invoice (from scratch or from recurring template).

(*edit - happens most often when viewing a previously saved invoice ... maybe 50% of the time)

 

To remove, go to COG > Choose What You Can Use 

You will most likely see that the Shipping checkbox is unchecked or has a grey tick.

Enable Shipping - you get a green tick.

Then disable again.