cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Level 1

Quickbooks 2019 with Mojave

Are they compatible?

 

1 Comment
Highlighted
Moderator

Quickbooks 2019 with Mojave

Hello Louis,

 

QuickBooks Desktop 2019 and earlier versions are not compatible with Mojave instead QuickBooks for Mac 2019 does. You can check out this article for more information: QuickBooks Desktop System Requirements.

 

Let me know if you have more questions about this.

Need to get in touch?

Contact us