cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Level 1

Sometimes when I charge a client's credit card, the transaction doesn't go through and QB deletes the client credit card information. This has been going on for months.

 
3 Comments 3
Highlighted
Content Leader

Sometimes when I charge a client's credit card, the transaction doesn't go through and QB deletes the client credit card information. This has been going on for months.

Hello, MarlonF.

 

I appreciate you taking the time to post your concern here in the Community. It's my priority to get to the bottom of this so you'll be able to charge your client's credit card and save the information.

 

To clarify, are you receiving any type of error message when you try to complete a transaction? Also, is this problem occurring with one specific client or several?

 

As an initial troubleshooting step to get started, I recommend clearing the cache in your internet browser. Clearing the cache will reset the browser, resolving any potential performance errors in QB. This article will walk you through the steps of this process, depending upon which browser you're using: https://quickbooks.intuit.com/community/Getting-Started/How-do-I-clear-my-browser-cache-and-temporar....

 

Please give this a try and let me know how things look afterward. I'll keep an eye out for your reply.

 

 

Highlighted
Level 1

Sometimes when I charge a client's credit card, the transaction doesn't go through and QB deletes the client credit card information. This has been going on for months.

No errors. I charge 20 to 30 credit cards from clients at a time.  I input the card information in the client screen and then go to receive payment to charge the card.  Then I click over to the Merchant screen (the gear>Account/Settings>Payments>Manage account) to confirm all cards have been charged. Then in a day or so I receive the email saying the money is on it's way with a total.  When I see the total is off, I go reconcile it. 

 

There is often one or two transactions that do not show in the merchant account side.  When I go to the QB client account, the payment shows, however if I go into the client detail and look at the payment & billing tab, the credit card information has been deleted.

 

This happened very frequently last spring. Lately it's been once per month. I talked to the Merchant customer service - they had no idea and said they have no record of any charges.  I talked with the QB customer service, a few times the customer service people had no idea. Once a person said it was a known issue and they were working on it.  They sent me a few updates saying, "not fixed, but we're still working on in."  But those stopped a couple of months ago.

Highlighted
QuickBooks Team

Sometimes when I charge a client's credit card, the transaction doesn't go through and QB deletes the client credit card information. This has been going on for months.

Thanks for getting back and clarifying this for us, MarlonF.

 

I appreciate all of your effort in trying to fix this issue. Since you're still unable to, I'd like to direct you to the support where you can get further assistance.

 

I'd love to take a closer look at the setup of your QuickBooks Payments account in your QuickBooks company file to determine the main cause of the error, so that I can come up with a solution.

 

I know you've already called our Merchant Services Team. However, only they have access to the resources necessary to accomplish this, so I highly recommend reaching out to them.

 

Please know I'm always available here for all of your needs, I'm determined to get this fixed for you. Thanks for coming to the Community, I'll be standing by for your response.

Need to get in touch?

Contact us